XBMC on wandboard

Hi,
I am pleased to announce a first image to evaluate my iMX6Q XBMC build on wandboard.

How to install

  • Download the compressed (xz) SDcard image
  • Extract it by using the xz utility :
xz -dv wand.bin.xz
  • Burn it on a sdcard (At least 2GiB) by using
dd if=wand.bin of=/dev/sdx bs=4M

With /dev/sdx being the sdcard device (for instance /dev/sdd)

How to test

Just Insert the sdcard and power up your board and you should be ready to give a try at it ! You can begin by playing the 2 1080p samples which are available on the sdcard.
Be aware that :

  • The Ethernet interface will try to grab its IP configuration using DHCP
  • you can login by using the account root/xbmcpoc
  • You can use the RS232 to login
  • A ssh server is up and running

There is also a micro synergy client available but it requires a few settings :

  • On the board, you have to set the synergy server address in /etc/hosts file (by setting an IP for synergy_server entry)
  • On you server, you have to set a configuration file with the “wandboard” client entry

Limitations

  • spdif and analog audio (sgtl5000) output are voluntary disabled for now (so that xbmc properly selects HDMI as output for sound)
  • wifi is untested (likely not working)

Underhood

This image includes:

  • uboot bootloader as it is packaged in several images from wandboard site
  • A linux kernel which is available here. This is my custom linux kernel for wandboard : I took the freescale official imx kernel from BSP V4.0.0 and I cherypicked all the commits that wandboard team applied on their android kernel.
  • A yocto RFS patched to insert
    • V4.0.0 GPU libraries
    • V4.0.0 firmware for VPU and VPU libraries
  • My “work in progress” XBMC for iMX6 which is available here.

Everything is still beta and my todo list is still quite long but it should enable you to give a first try to XBMC on this great board…

Any feedback is welcome
Best regards

Update : Following a user feedback, it appears that I forgot to remove my public key from /home/root/.ssh/authorized_keys. If you care about it, remove it….

74 thoughts on “XBMC on wandboard

  1. thanks for the hard work in getting this working,

    will this image run on a gk802 without any modifications ?

    looking forwards to trying this,

    cheers

  2. Hi anthony,
    I guess the RFS by itself can be used as it on a GK802 and the kernel in /boot is for gk802 in fact ! (because the wandboard kernel is not in the RFS) but you cannot use the whole image as it (uboot are not the same)
    I guess the best way it to take a previous image for GK802 and to replace the RFS
    You can download the latest RFS alone here : https://stephan-rafin.net/owncloud/public.php?service=files&t=30df3dbb80739a23ddff152e1750e5ff.

    Regards

  3. Thanks for getting this up and running… works well here – pretty remarkable to be doing 1080p in 3W.

    I guess I must be missing LIRC or something because the MCE receiver/remote is ignored, but this is a pretty small thing.

  4. Hi Tom,

    You are right; some pieces are missing to get lirc to work.
    I add it on my todo list… 😉
    Regards

    • Hi Adam,

      Sorry no wifi nor BT officially supported for now. But it will be available in a coming image for sure (There is no hard work on this side : I only have to package properly a few additional bricks)…

  5. Pingback: A Preliminary XBMC Image is now Available for Wandboard, GK802

  6. Pingback: XBMC image for wandboard dual | Stephan's blog

  7. I tried this on my gk802, I only get a terminal like window. How can I execute XBMC or any of the samples?

  8. Thank you Stephan.
    I am playing with the wandboard quad for a few days.
    I like your xbmc-wandboard-image very much.
    Everything I tested (ssh, nullmodem, some changes on fstab) works fine for me.

    Regards
    Norbert

  9. Hey Stephan, great work so far! Last night, I started it up on my wandboard quad. I was looking a the debug code across the screen and it was getting 94 fps, and seemed pretty responsive then it froze and crashed. I’m not sure if it overheated. The quad has a pretty good heat-sink on there. I know it is a work in progress, but I have issues with my sharp 32inch 1080i TV, on other xbmc clients it is possible to readjust the screen so there is no cut off. The only resolution was 1280/720.

    • Hi caulin,

      When such a crash occurs it would be interesting to post via a copy/paste online service the xbmc log (which is in /home/root/.xbmc/tmp/ folder)
      I have never experienced overheating with my wandboard quad so I don’t think it is the root cause of the crash…
      There is only one resolution yes : the one which is set by the bootloader u-boot(then the framebuffer uses it and so does xbmc) and it is 1920×1080@60 by default in my image.
      Do you have issues only with my image ?
      If you want to switch to 720p you can change uboot configuartion :
      Plug a serial line on DB9 (settings are 115200n8)
      Hit ESC when uboot appears
      type at uboot prompt :
      set bootargs ‘console=ttymxc0,115200 root=/dev/mmcblk0p1 rootfstype=ext2 ro video=mxcfb0:dev=hdmi,1280×720@60,if=BGR32 consoleblank=0’
      saveenv
      run bootcmd

      PS : the ‘set bootargs …” line ends on the second quote.
      Regards

      • I’ve been trying the Quad image on my Wandboard and have experienced similar lockups on the three times I’ve had it running. On each occasion it would work for a while (longest was about 20 minutes / shortest about three minutes) and then freeze for no apparent reason. The WB didnt appear to be hot, so do not think it is over-heating. Next time I try I will grab the log and if anything useful I will post.

        On the last attempt I managed to play both the test files and these worked splendidly well – the picture quality is as good as I have achieved with XBMC on a number of other devices and the GUI responsive. Very impressed!

        One point – no NTFS is installled so I couldn’t access any files on my USB drives, but I guess that can be installed.

  10. Awesome job! I played around with the wb quad image and it plays absolutely all my movies.
    Could you update the kernel image for the correct amount of ram and if you could build openvpn package for yocto it would be fantastic.

  11. Pingback: XBMC image for dual (part 2) | Stephan's blog

  12. Pingback: iMX6 XBMC : What is coming next ? | Stephan's blog

  13. Hello,

    I’m thinking on buying this board for media center, mainly for playing mkv videos and music + home file server(torrents,samba etc. owncloud) So, the xbmc looks promising on this little thing, does it lags or stutters and does it crashes? How about just using linux with smplayer or vlc? Is it possible with hardware video acceleration?

    Does it decode DTS?

    Thanks for the answers.

    • Hi

      This XBMC port is still work in progress and may crash from time to time (especially with untested plugins or specific codecs).
      Yet for the basic use : Play mkv (h264codec) videos, it already works quite well without lags
      As far as I know nobody has added imx6 hw support for smplayer or vlc as I have done for xbmc…
      xbmc is able to decode dts by sw yes…

      • Tnx. I’m a debian,gentoo and now arch user and I’m searching for a low powered htpc. This board is very fits he picture in hardware and connectors so it woul fit m,y needs. I’m gonna use it for more than a media player but that optioon is a must. My tv reads 80% of mkv’s and that’s why I want something that can replace the player that is embedded in tv. Do you know or anybody here is there a board under 10w power consumption that can read all the major video formats and dts under linux? As far as I know wanda board is the closest. How about pandaboard es? Or cubox(but only spdif…)? Btw does wandaboard quad has full android support?If yes, I presume that xbmc for android has a blob drivers for vivante g2000 with full acceleration support?

        I’m definitely appreciating your work on xbmc on linux on this board,I think there are a lot of others who are following this project and if you manage to polish xbmc to work with full support we should definitely give you some donation for our sign of appreciation 🙂 keep up the good work and I appologise for bad english.

        • Hi,

          There are definitively many ARM boards and/or devices out there but when you want gbps ethernet/sata/spdif dual displays and quite powerful cores with support for both Linux and Android then imx6 boards are, to my mind, excellent candidates…

          Apart from wandboard, these devices http://utilite-computer.com/web/utilite-models seem interesting (they are a little more expensive but provide additional Ethernet on PCIe and ssd on sata). I will very likely support them as I should receive a quad model soon…

          Regarding android I don’t know if XBMC for android provides full hw acceleration out of he box : In fact decoding is not performed by the vivante GPU but by the freescale VPU : I guess that in the future we should have proper libstagefright support for android XBMC and that we will have (maybe it is already the case, I dont know because I don’t care that much about android) a libstagefright which makes use of imx VPU.

          I continue my work on XBMC and and I will for sure provide support for all formats that can be handled by the VPU …

            • Hmm really iMX6Q wandboard is not comparable to Rpi or cubieboard2 to my mind. They may be perfectly OK for your needs but, as I said in my previous post, when you want gbps ethernet/sata/spdif dual displays and quite powerful (multi)cores with support for both Linux and Android then they cannot compete…

      • I have found this little device Lenovo q190. The wandboard wuad with shippment woul cost me about 150$. The q190 would cost me around 280$ here in my country – http://www.amazon.co.uk/Lenovo-IdeaCentre-Ultra-Factor-Desktop/dp/B00DPJZQBG But with no ODD, Windos 8 and with 320GB. I will see how things go up with the wandboard quad but this little thingy reads every 1080p out there and it flies with linux os and would serve my needs in htpc domain. I have still not crossed the wandboard becase it is definitely lower priced and even more low power compsution device…

    • Hi peter

      I am currently working hard to sync with latest yocto release and to build a hf image.
      I disabled SPDIF because of a saturation issue (and because xbmc was unable to use several alsa devices) but I should address these issues and provide a brand new hf image with additional codecs and SPDIF support next week I hope…

      Regards

  14. This looks veeeeeeery interesting to me! You’ve done a great job!! It outputs audio via HDMI, right? Does it bitstream HD audio formats (TrueHD and HD Master Audio)?

    • With this first image it only output to hdmi right but I have not been able to test HD passthrough for now.

      I have just improved my XBMC build to be able to use any device (analog, SPDIF or HDMI) and it mostly works (well there is a subtle issue with volume setting but I understand what is going on…).
      When I release this new image it will be time to test these bitstream use case. Unfortunately I will only be able to test dts on my side as I don’t have a HD receiver but I hope to get feedback from users and to be able to solve issues if any…

  15. Dear Stephan:

    I had got my new Wandboard Quad execution on 5V 2A DC power adapter.
    In order to make sure that the board works, I have tested the images ( include: Android & Ubuntu ) on the official download web site. The images works very well.

    I want to try the XBMC application, I referred your blog and I tested the image from your blog.
    However, I am unable to get any video output on my HDMI monitor. The monitor was always black. I can boot up but the screen never display.

    Is it possible that the power adapter is not enough ?
    Or what’s the problem ?

    Thanks for your help!

    Best regards,

    Arthur

    • Hi Arthur,

      When you boot my image, are you at least able to see the yocto splash boot screen and/or the XBMC GUI or does the screen remain black ?
      Is your screen able to display 1080p ?

      Stéphan

      • Dear Stephan:

        Your help was greatly appreciated.
        As your suggestion, my screen display only support 1080i. I tested on the other monitor device. It works very well.
        Thanks for your help again !!

        Best regards,
        Arthur

        • Nice to read that it works… You can make it work on your 1080i screen but you have to change kernel parameters in u-boot…
          Regards
          Stephan

  16. Hi,

    your blog inspired my to buy a wandboard quad. I hope it arrive next week. I will do some tests. For me are following things very important because I want to change the hardware from raspberry to wand.

    LIRC support. Without I having a very slow WAF…:-)
    bitstream support

    Its long time ago you post the last quad image. Is there some approvements ongoing?

    • Hi stefan

      I have a personal interest in lircd so I will work on it quite soon : there is no reason why we could not get it to work easily.
      Bitstreaming should work but has to be tested : You want it on hdmi or spdif interface ?

      My new image is late : I was not able to work on it as I expected today. But I only have a little timeout issue to solve and to package the whole thing so it will happen this week for sure.

      regards

      • Hi,

        sounds good for me that you also have personal interest to get LIRC running.

        I only need HDMI. SPDIF would be nice for squeezelite but at first HDMI for XBMC.

        I read below that you have a later this week a new image. I hope my new wandboard quad will arrived also this week. If it arrived I will test your new image and will give you feedback.

  17. Finally got around testing XBMC on my Wandboard Quad. Great work!

    The kernel reports only having 496MB:
    [ 0.000000] Memory: 496MB = 496MB total
    [ 0.000000] Memory: 495752k/495752k available, 192376k reserved, 0K highmem
    XBMC also reports this low number.
    I would expect more something like this:
    [ 0.000000] Memory: 80MB 1792MB = 1872MB total
    [ 0.000000] Memory: 1884244k/1884244k available, 212908k reserved, 1409024K highmem
    This probable can be fixed by adjusting the kernel config

    In XBMC I cannot use NFS to connect to my NAS while the kernel does support it.

    My Quad has issues booting your image (with the uSD I am using). 9 out of 10 times it gives a kernel panic not able to find the rootfs. After adding ‘rootwait’ to the bootargs it boots a bit better.

    Hopefully you’ll be able to release a new image soon.
    Keep up the great work!

    • Hi Jurgen

      My new image should be ready before the end of the day.
      All the issues you mention are solved : total amount of memory, libnfs so that xbmc can access NFS mounts (XBMC does not use kernel support but relies upon the userspace library libnfs), and “rootwait” option so that the RFS will be properly mounted everytime whatever the sdcard speed is … I am working on it…

      Stephan

  18. Excellent work! One thing I couldn’t get going is the micro synergy. I added my server’s ip to /etc/hosts and rebooted. I added the wandboard to client list. Is there any other specific thing I need to configure in server to make it work?

    • Hi Nicolas,
      Did you try to kill the usynergy client and to launch it again on your target ? It may display a specific message which would help us to understand. Also on the server side, try to display logs when it tries to connect… My configuration is very trivial on server side (called “gary”) :

      section: screens
      gary:
      wandboard:
      end

      section: links
      gary:
      right = wandboard
      wandboard:
      left = gary
      end

      Keep me informed, it should not be too difficult to get it to work…
      Regards

  19. Right off the hop, I’d like to acknowledge your efforts in this area…

    Not everyone buying a Wandboard is a developer — matter of fact, there are probably more guys like me out there who own one of these, guys with a few years experience running GNU/Linux-based operating systems as their main desktop OS who saw in the Wandboard Quad an economical desktop platform, than there are developers who own one.

    The default images on offer at the wandboard.org site are way too buggy to provide what I would call a satisfactory multimedia experience so I’m hoping to have better luck with your image.

    At the top of this post, under the “Limitations”, it says:

    “- spdif and analog audio (sgtl5000) output are voluntary disabled for now (so that xbmc properly selects HDMI as output for sound)”

    In a comment dated August 23 in this same post, you state that “I have just improved my XBMC build to be able to use any device (analog, SPDIF or HDMI) and it mostly works (well there is a subtle issue with volume setting but I understand what is going on…)”.

    My current setup relies on a 10″ LCD for display and SPDIF for audio, that is to say, I use the HDMI cable for video only.

    I just downloaded the image (wand.bin.xz) at https://stephan-rafin.net/owncloud/public.php?service=files&t=9300a8a9b904f4b26249b149efec52d1 and I’m wondering if it is indeed the latest image and if audio through SPDIF is working.

    Thanks

  20. Hi,
    thanks for the built – to be honest I’m a beginner in terms of Linux and specially on the wandboard (Quad). I tried to make my wandboard boot this image (micro-SD in module-SD-slot). So I downloaded, extracted and took it to the microSD card. For the first few tries I took Windows and win32diskimager, the I tried using Debian an dd. All copying was reported to be successful but the wandboard never did boot. The TV recognizes a HDMI signal @1080p but the screen keeps being black. Booting with the images from wandboard.org works perfectly. Can you give me any hints what I could do? Can I use the serial port for “debuggin” like connecting a serial port USB Cable like the FTR232?
    Thank you very much, greetings from Germany – Michael

    • Hi Michael
      Is your TV 1080p capable ?
      If it is I cannot guess what is wrong. You can definitively use a USB->RS232 adpater and a null modem cable to connect to your wandboard and have relevant information about what is wrong with your boot. The settings are 115200n8. (By the way, the FTR232 based devices are very good but you can have much cheaper chips which ensure the same functionality…)
      Stephan

      • Hi Stephan, thank you for your answer. Well RS232 was really easy but unfortunately I can’t find any “alterting” sequences. U-Boot looks correct, 1080p@60Hz is set. I’m pretty sure my TV (Samsung UE46F5000) is capable of 1080p since Yocto 1.4 and Ubuntu 11.10 work seamlessly on the wandboard. Furthermore my Raspberry Pi (please don’t blame me for having used this lousy Broadcom SoC) with XBMC did a good job @1080p. I tried using other TVs (all Samsung) – screen black black black. I don’t think this should be an issue. Well I’ll try to poste the boot-log from the UART for you …. shall I post it here?

        OffTopic: Do you really have good experience using these “cheap” bridges like the PL2302 by Prolific? I’ve had so much trouble with these guys. Especially in terms of working with really good UART-RS232 Transceivers like the SN75C3221. I read about problems using MAX232 with it but though – ok maybe some idiots must have messed up chargepumps etc…. but no – my PL2302 simply didn’t stick to RS232 specs and it didn’t work – even using “better” UART-Transceivers. Well nevertheless – using FTR232 instantaneously solved all my problems 😀

        Thanks a lot
        Michael

        • Hi Michael,
          OK, nice to have this LS access,
          Thanks to the LS, can you check that the kernel boots properly and that you have shell access ? (The underlying question is : is it a video only issue )
          If everything else is fine I would advise to change the video parameter to match the one that work with other images you mention (In my image these u-boot parameters are stored in the boot.scr file)

          Regarding cheap bridges like PL2302 or ch341, I use them quite often faced to many different devices (and thus different transceivers) and have experienced a similar issue only once (I cannot remember the involved RS232 transceiver)

          Best regards
          Stephan

  21. Thanks for all.

    I’m just a beginner in terms of Linux and specially on the wandboard (Quad). When i connect to USB a NTFS drive, i see on screen that its mounting properly but after i can´t acces to the disk, doesn’t appears in the file list. Can you help me? Sorry for my english.

    Happy new year from Spain.

    • Hi Harold,

      I have not yet released an official image with full support for liveTV but it will happen soon as it now works quite fine…
      Have you built your image or do you use a prebuilt one ?

  22. I have tried the new image XBMC Yocto….
    only for few minutes….it looks a little slow….even going from one menu to another…
    my Raspberry pi runs much faster then that…
    why its slow?….
    i have bought this board thinking that it will run much faster then RPi…but, it does not look like it can beat RPi….

    • Hi

      In fact, you post in the wrong article if you really try the latest image as this post is 6 months old and related to an old release.
      You have bought a wandboard quad right ?
      Don’t worry this board is definitively faster than your Rpi.
      Regarding XBMC UI slowness, please check that your advanced settings holds configuration for dirty regions
      Also we have to compare apples with apples. Rpi does not render at 1080p : It renders at 720p and upscale to 1080p while the current imx6 version really renders at 1080p, maybe I was too ambitious here and will implement a similar approach…
      Regards

  23. Thank you for your quick reply….
    i actually saw the link for the XBMC Yocto here, so i posted here….sorry about that.
    i am going to play with it a little and see how it works….will change the advance settings and post on the XBMC Yocto blog….

    Thank you again !

    • Fine…
      The current xbmc version may still require a little massaging but generally speaking your new board will have better performances than your Rpi for sure ….

  24. oh and yes, i have bought the Quad version….received it today from Mouser.com….since i am in Texas, takes a day from them to my door step 😉

  25. Pingback: The wandboard | JB's DEV STORY

Leave a Reply

Your email address will not be published. Required fields are marked *