Yocto image issues

Home Forums i.MX6 XBMC support Yocto image issues

  • This topic has 67 replies, 2 voices, and was last updated 5 years ago by stephan.
Viewing 15 posts - 16 through 30 (of 32 total)
  • Author
    Posts
  • #547
    Gabriel Guzman
    Guest

    @Stephan

    That fixes the issue. Was able to boot no problem with the new image.
    Thanks!

    gabe.

    #556
    stephan
    Keymaster

    @ gabriel
    Thanks for feedback…
    I push the changes in my layer so that I will never again forget this extra step (not required for most utilite users who use the uboot in SPI flah, I don’t why you don’t but I know how to deal with it so … 😉 )

    Regards

    #558
    Philippe
    Guest

    Hi Stephan,

    Thanks for this outstanding work. Worked at once on my wandbord dual !

    Moving further, I would like to install some debian packages and I am struggling a bit (smart does not want to create a apt-deb channel and dpkg seems not to be installed either). Any clue ?

    Thanks and regards,

    #560
    phil4444
    Guest

    Hi,

    i tried to share my internet over lan according to this guide:

    https://wiki.archlinux.org/index.php/Internet_sharing

    iptables gave me this error:

    ##########
    root@wb:~# iptables -t nat -A POSTROUTING -o wlan0 -j MASQUERADE
    modprobe: FATAL: Module ip_tables not found.
    iptables v1.4.19.1: can’t initialize iptables table `nat’: Table does not exist (do you need to insmod?)
    Perhaps iptables or your kernel needs to be upgraded.
    ##########

    is there a way to accomplish that?
    would be a nice feature..

    ######################################################################
    another problem i am facing is my display resolution of my hdmi->dvi monitor (1680x1050M@60m worked for uEnv.txt), for your image i created a new boot.scr but the screen stays in low graphic mode

    thx in advance!

    regards

    #582
    Trevor
    Guest

    Stephan,
    I have a utilite pro, and I have installed utilite_yocto_v0.0.4_ssd.tar.bz2 to the internal SSD.

    My kernel boot parameters are: (cat /proc/cmdline )

    console=ttymxc3,115200 root=/dev/sda2 rootfstype=ext4 rw rootwait video=mxcfb0:dev=hdmi cm_fx6_v4l_msize=128M vmalloc=256M fbmem=48M

    However, when the system boots it appears the the accelerated drivers are not loading. None of the /dev/videoX devices exist, and I not seeing an obvious error message in the kernel logs.

    I am getting the following error when I try and play a video file from XBMC (in /tmp/temp/xbmc.log)

    ERROR: AllocateBuffers – Error while trying to open /dev/video17

    I can see the drivers load (dmesg, and in /dev), when I boot the system with the latest compulab, ubuntu image.

    Thank you for your help!

    -Trevor

    #583
    Trevor
    Guest

    ok, after searching through comments in the blog postings, I added the following to the boot parameters: “cm_fx6_v4l DMFC=3”

    The drivers now load, I am however getting the occasional (every ~45 seconds) black screen, and kernel message:
    imx-ipuv3 imx-ipuv3.0: IPU Warning – IPU_INT_STAT_10 = 0x00100000

    I saw the bug report on this issue, (http://stephan-rafin.net/trac/ticket/6) and a reference to setting the video to 16bpp.

    How do I set the video to 16bpp? From the kernel boot param or inside of XBMC?

    Thank you again,
    Trevor

    #584
    stephan
    Keymaster

    Hi trevor

    You cmdline is not the one you should have. I don’t know how exactly you have installed the image on ssd but the boot.scr of my rfs should be used and it hodls the following

    setenv bootargs console=ttymxc3,115200 root=/dev/sda2 rootwait rw video=mxcfb0:dev=hdmi,1920×1080@60,if=RGB24,bpp=16 consoleblank=0 cm_fx6_v4l dmfc=3
    fatload sata 0 0x10800000 uImage
    bootm

    Apart from it your issue is mainly solved by another patch in my kernel (which sets IPU priority on AXI bus)

    Regards
    Stephan

    #585
    Trevor
    Guest

    Stephan,
    I changed by bootargs, and not things are working much better. I am able to play videos at 1080p without the earlier issues.

    One more question. Are there plans to add the mythtv pvr plugin to the image? I can not seem to find it. The documentation I found implies it is typically pre-bundled.

    http://wiki.xbmc.org/index.php?title=PVR/MythTV

    -Trevor

    #587
    stephan
    Keymaster

    hi Trevor,

    Thanks for feedback
    Yes of course I will have a look at mythtv : In fact all other pvr addons are built, I don’t know why this one isn’t (likely top be a dependency issue)
    Regards

    #588
    Ralix
    Guest

    Hi phil4444 ,

    The same problem I have with my Archlinux on the utilité. I made a PKGBUILDs for the kernel and adapted the KERNEL_CONFIG. Stephan has just built the kernel not with for iptables. But this is quickly adjusted with make menuconfig. If you have built everything new, you can use iptables. I needed this for hostap with me.

    #1438
    Bruce Quinton
    Guest

    Hi Stephan,
    I’m running a Utilite Pro using you 0.0.4 image. The issue I have is that if I have my two movie external USB drives plugged in (2Tb each) the system hangs during boot (eg the “Yocto Project” logo is on the screen but the progress bar is stuck), if I unplug my drives and reboot it boots fine, I then plug my drives back in and I’m all working.

    Is there something I can change in the boot parameters that may help?

    note: if I have only one drive plugged in the boot “pauses” at the same location for around 20 seconds then continues to boot correctly. (most times, some times it hangs but more often then not it boots correctly)

    Regards Bruce Quinton

    #1517
    Rogier
    Guest

    Hi Stephan,

    Thanks for all your work in developing this image. I received the Rev C1 Quad verion of the Wandboard. This image boots fine but doesn’t recognise the new Wifi adapter. I looked into upgrading the system, but seems that the password is not empty to access the system from the serial port.

    #1524
    stephan
    Keymaster

    Hi Rogier

    Really ? (well it should lol)
    Which exact image do you use ?

    Regards
    Stephan

    #1551
    ototu
    Guest

    Hi Stephan sorry to disturb

    Since last december, I am an happy user of your yocto images running on a wandboard dual.

    Today I just saw that you dropped your repo for this board. Should I consider it definitive and go forward another distro (maybe arch), or maybe can I hope you bringing it back ?

    Thanks for the job anyway

    #1562
    stephan
    Keymaster

    Hi
    Sorry it is simply a mistake while forcing a rebuild 3days ago…
    I relaunch the build for your target : everything should be back in a few hours, if not tell me…
    I will post regarding my support for yocto image. But the general idea is : I still use it by myself for my daily devs so I keep it updated.
    But I do not advertise it a lot now because other more generic well packaged distro are available
    If you are pleased with this image, you will be able to continue to use it (and the build in progress will provide the very last sync with xbmc 13.1)
    Regards
    Stephan

Viewing 15 posts - 16 through 30 (of 32 total)
  • The forum ‘i.MX6 XBMC support’ is closed to new topics and replies.

One thought on “Yocto image issues

  1. Pingback: Yet another yocto image | Stephan's blog

Comments are closed.